Поставил Debian, там по умолчанию есть браузер Iceweasel (та же лиса, только под другим именем). Всё бы хорошо, но эта сучечка отказывается работать с блогоПанелью. Вот такая вот пичялька.

Подскажите, где в блогоскрипте подправить (я подозреваю, что-то в install.rdf) чтоб блогпанель завелась.

И еще. В Debian есть еще один браузер, который называется Epiphany. Как его корректно выпилить из системы?

Пушо по дефолту с ним выпиливается половина гнома почему-то.

Tagged with →  

16 Responses to Iceweasel и Epiphany

  1. RohBlank:

    в дебиане наверное древний лис. может попробуй поставить поновее отсюда http://mozilla.debian.net/

  2. Csbin:

    Iceweasel стоит самый последний (

  3. Csbin:

    блогопанель и гресманки фиксед. А вот Эпифани доставляет меня в ступор..

    [email protected]:/home/yug# wajig dependents epiphany-browser
    r epiphany-browser-data
    d epiphany-browser-dbg
    d epiphany-browser-dev
    d epiphany-gecko
    d epiphany-webkit
    d epiphany-extensions
    d gecko-mediaplayer
    s gnome-do-plugins
    s gnome-panel
    s gnumeric
    d gnome-core
    d postr
    r totem-mozilla
    d gnome-core
    s gnome-panel
    r epiphany-browser-data
    r totem-mozilla
    d epiphany-extensions
    [email protected]:/home/yug# wajig remove epiphany-browser
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Следующие пакеты устанавливались автоматически и больше не требуются:
    libmono-addins-gui0.2-cil mono-2.0-gac tomboy libmtp8 libnm-glib-vpn1
    libgnomepanel2.24-cil libglade2.0-cil python-mako
    mobile-broadband-provider-info libglib2.0-cil network-manager gdebi
    evolution-exchange libgconf2.0-cil python-aptdaemon-gtk update-manager-core
    gnome-codec-install python-aptdaemon liferea-data cli-common
    gnome-themes-more rhythmbox libgexiv2-0 gnome-office update-manager-gnome
    libart2.0-cil update-notifier-common gdebi-core update-notifier
    libgnome2.24-cil libndesk-dbus1.0-cil libgpod4 libmono-cairo2.0-cil
    gedit-plugins network-manager-gnome shotwell dnsmasq-base
    gnome-themes-extras libgmime2.4-cil software-center libmono-i18n-west2.0-cil
    simple-scan libmono-addins0.2-cil python-markupsafe libgee2 python-webkit
    libmono-posix2.0-cil rhythmbox-plugin-cdrecorder libmono-security2.0-cil
    gtk2-engines-smooth libgtk2.0-cil mono-gac python-vte aptdaemon
    usb-modeswitch-data media-player-info ppp tcl libmono-sharpzip2.84-cil
    usb-modeswitch libmono-corlib2.0-cil libgpod-common rhythmbox-plugins tcl8.4
    mono-runtime liferea libndesk-dbus-glib1.0-cil binfmt-support
    libgnome-vfs2.0-cil transmission-common modemmanager totem-mozilla
    libmono-system2.0-cil transmission-gtk
    Для их удаления используйте ‘apt-get autoremove’.
    Пакеты, которые будут УДАЛЕНЫ:
    epiphany-browser epiphany-extensions gnome
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 3 пакетов, и 0 пакетов не обновлено.
    После данной операции, объём занятого дискового пространства уменьшится на 4.596 kB.
    Хотите продолжить [Д/н]?

  4. RehLt:

    у каждого пакета в системе стоит галочка «установлено юзером/установлено автоматически». У меня тоже при удалении вино сотня пакетов хотела покончить с собой. Точную строку для гугла не подскажу, но помню что эта галочка может редактироваться прямо в синаптике.
    Вино вроде так и стоит, кстати.

  5. RARLinux:

    Пакеты, которые будут УДАЛЕНЫ:
    epiphany–browser epiphany–extensions gnome
    Что не так?

  6. RARLinux:

    ваша ошибка в том, что вы не читаете описания пакетов, а туда же

  7. Rodno:

    Это метапакет, который ставит все-все компоненты гнума.

  8. Csbin:

    Я понимаю, что это метапакет, более того, в гуглах есть рассуждения на форумах, что именно он кривой, но как его править, и главное что в нем править, я не нагуглил 🙁

  9. RARLinux:

    если ты понимаешь, что это метапакет, почему ты не хочешь его удалять и называешь его удаление удалением половины гнома?

  10. Csbin:

    Да, но потом отпадает возможность сделать в будущем apt–get autoremove на любую инсталяцию. Вроде покурил интернет и попробую вот такой солюшн через aptitude (парсер, перестань парсить!):

    # aptitude unmarkauto ‘?reverse-depends(gnome) |?reverse-recommends(gnome)’
    # aptitude unmarkauto ‘?reverse-depends(gnome-core) |?reverse-recommends(gnome-core)’
    # aptitude unmarkauto ‘?reverse-depends(gnome-desktop-environment)» |?reverse-recommends(gnome-desktop-environment)’

  11. RARLinux:

    что такое «возможность сделать в будущем apt–get autoremove»? Если тебе какой-то пакет нужен — пометь его как нужный. Если тебе какой-то пакет не нужен — удали.
    И я не уверен, что aptitude уже использует системный список автоустановленных пакетов.

  12. Csbin:

    При удалении, пакет оставляет за собой кучу мусора, который я бы не хотел держать в системе, поэтому я периодически после apt-get purge делаю apt-get autoremove, для удаления либ и прочего гуавна,к оторое мне более не нужно.

    Так вот, если удалить метапакет gnome, то в будущем я не смогу чистить систему после удаления других приложений, если система мне скажет «Следующие пакеты устанавливались автоматически и больше не требуются:», потому что помимо гуавна от приложений авторемув почистит заодно и гном.

  13. RARLinux:

    пометь нужные тебе пакеты как нужные, это всегда полезно.

  14. Csbin:

    О! точно! Спасибо! И кстати apt-mark unmarkauto намного приятнее того, что я нашел (: ++

Добавить комментарий