Привет nix_блог))) Босс обещал поднять мне зарплату, если я смогу обновить 3 сервиса на своей работе: jira, confluence и redmine.
Конфлюенс уже новый и с обновлениями проблем не возникает. Осталось 2.
redmine версии 1.0.0 и нужно обновить до актуальной, а jira версии 3.11 и нужно тоже обновить до актуальной. Если с редмайном хоть как то ясно, то вот с жирой самая большая проблема, потому что сразу до актуальной поднять не получится, нужно обновляться постепенно, примерно 7 раз, и самая большая проблема в этом — сохранить все данные.
Вознаграждение тому, кто поможет — ящик пива!

КПЗ: Админ 80lvl

размер 150x185, 55.80 kb

Tagged with →  

79 Responses to Обновить 3 сервиса на своей работе: jira, confluence и redmine.

  1. R0bPhone:

    Помочь нужно с редмайном и жирой. Пиво может быть очень хорошим, а может даже и не пивом. Плиииииз!

  2. JihTunes:

    Забекапь базу, разверни рядом — и обновляй сколько влезет, потеряешь один раз данные — не страшно.

  3. R0bPhone:

    : дело в том, что я этого никогда не делал. Я совсем какой-то недолинуксоид, у меня все ломается постоянно. Я на тестовом сервере это все развернул, базы прикрутил, но он постоянно спрашивает какие-то $homedir, а я неебу че это такое. сталкивался с похожим только когда делал export JRE_HOME=/usr/bin/jre для работы жиры. хотелось бы совета от человека, который этим занимается с закрытыми глазами. ну или ман на русском. спасибо

  4. JihTunes:

    : с маном не помогу, да и нет его, думаю на свете.
    Если что — пост, могу поотвечать на вопросы.

  5. Iksam:

    а мой босс упрекает, что долго вожусь с установкой и переносом. плюс куча не менее ебуче-глючных плагинов. сука глаза бы мои не видели эту жиру, в рот она ебись

  6. R0bPhone:

    : а ты с линуксом на твою мать?

  7. R0bPhone:

    : солидарен

  8. NziSwet:

    : ты явно мегаплан не админил

  9. NziSwet:

    как уже заметили очевидное — бекапь базу и наслаждайся. ну и не ломай работающее, подними рядом ещё инстанс и потихоньку его апгредь (нужно скопировать всего-то директорию с жабой и жирой).

  10. R0bPhone:

    : с какой жабой? че то не догнал

  11. NziSwet:

    : с джавой

  12. R0bPhone:

    : а вообще реально обновить жиру древнючей версии 3.11 до актуальной и данные не проебать?

  13. R0bPhone:

    : или лучше новую сразу поставить и попытаться данные прикрутить?

  14. Rodef:

    : Реально, даже был опыт. Можешь постировать, если хочешь.

  15. Iksam:

    : я не админю, а делаю полный переход с аутсорсинга на свою платформу. ничего сложного, за исключением того, что это всё у них работает через жопу. какого хуя например не запускается crowd? а вот хуй его знает, прежде чем его запустить надо отконфигурить файлов гору и маленькую тележку. и так с любым продуктов. миграция проектов так вообще на грани фантастики блядь. уже сука сил нет никаких

  16. Iksam:

    : я делал восстановление с версии 4.3 на 5.0.5, просто подсунул бэкап в xml и она его схавала.
    с конфлюенс было по другому, бэкапы жрать он не хотел, я его научил. сделав совбственный бэкап, заменил в нем содержимое каждой папки на то, что мне было нужно и он это схавал. еще есть вариант поставить версию поновее восстановиться, предварительно потушив версию новую рабочую, потушить старую на которую восстановился и подсунуть базу новой. конфлюенс и это схавал. в общем тут искроёбство

  17. Iksam:

    : ну и да, вчера пытался ограничить яву в обжорстве, не помогло. делал это через setenv.sh, оставил на инстанс 512 мб. сервак один хуй хуеет, причем от явы. надо бы поправить явовский xmx, никто не занимался? а то я пока только читал

  18. R0bPhone:

    : у нас вообще отдельный сервак под это и никто на прожорливость вроде не жаловался.

  19. Rodef:

    : Ну я админил. Или ты про коробочные версии?

  20. Iksam:

    : у меня на vmvare отдельный хост

  21. Rodef:

    : Казя, жира съедает всю память, все процессорные ядра и всю дисковую подсистему, сколько ей не выдашь. И всё равно тормозит.

  22. Xxxhlam:

    : в пост входит -Xmx512M

  23. Iksam:

    : во! я чето придумал. напишу под фотонькой вопросик

  24. NziSwet:

    : да, про коробки. пхп 5.2.6 сука

  25. NziSwet:

    : да конечно реально

  26. NziSwet:

    : > с аутсорсинга на свою платформу
    ты имеешь в виду с SaaS на коробку?

    через жопу — это очень мягко сказано. порой в эксепшенах джавоговорящей жиры разобраться проще, чем в том, как мегаплан реагирует на ошибки

  27. NziSwet:

    : ну ограничил ты память, проц-то от этого меньше жраться не будет.

  28. Rodef:

    : Вообще-то специально поддерживают совместимость с пыхом 5.2.

  29. Rodef:

    : Пример, пожалуйста.

  30. Iksam:

    : в смысле мы платим за аутсорс чужой компании, у меня задача поднять свой сервис. сегодня ебанулась ява, сейчас ничего не работает. ну и беда какая-то с жирой и конфлей, тормозят нереально и постоянно требуют пароль. хз, что им надо

  31. NziSwet:

    : ну вот я щас прям тебе буду искать что ли? оно пока работает и лишний раз трогать я не хочу.
    а ты в мегаплане работаешь, что ли?

  32. NziSwet:

    : >постоянно требуют пароль
    ммм, настройки продолжительности сессии? или какой пароль?

  33. Rodef:

    : Ну как бы да.

  34. NziSwet:

    : из-за Zend Optimizer, поди?

  35. NziSwet:

    : о, клёво, мы тут собираемся новую версию купить, можно я у тебя консультироваться буду?

  36. Rodef:

    : Лучше у отдела продаж консультироваться 🙂

  37. Rodef:

    : Для коробочников — да.

  38. GVrin:

    : Ой, а расскажи про мегаплан, что там как там? можно пост

  39. GVrin:

    : тогда и ты про мегаплан расскажи! коробочной версии что нужно для счастливой жизни? только собираемся брать.

  40. Xxxhlam:

    : ой блядь.

  41. Iksam:

    : xmx256 лучше не делать. 768 — 2024 поставил и всё зашуршало. вроде нормально.
    единственный момент, иногда бывает резко слетает и в каматоз уходит. я думал, может кэш явы сбрасывать периодически, каким-нибудь скриптом например.
    но позже выяснилось, что она сама периодически сбрасывает

  42. GVrin:

    : ну рассказывай уже, не томи.

  43. Xxxhlam:

    : да это лютый адовый пиздец — ваш мегаплан.
    как-то довелось столкнуться с обновлением, это тот еще квест.
    кстати, когда я работал на Шаболовке, то видел wifi ssid этой конторы, они где-то рядом сидели.

  44. Xxxhlam:

    : еще раз — кеш сбрасывает приложение, а не джава машина.
    а вообще — чем больше памяти дашь ей, тем веселее будет работать, это я тебе еще в посте сказал

  45. GVrin:

    : в самых тяжелых случаях существует платный саппорт.
    я думал что-то по делу скажешь.

  46. Xxxhlam:

    : а что именно по делу то?
    стоит, вроде работает, если его не трогать и не обновлять

  47. GVrin:

    : вот это и главное

  48. Rodef:

    : пахапе, постгрес, зендоптимизер, мемкеши всякие, ну всё как всегда.

  49. Rodef:

    : Да я ухожу отсюда через неделю уже, чо 🙂

  50. NziSwet:

    : молодец, я бы тоже ушёл

  51. NziSwet:

    : я не рекомендую связываться с этим говном. больше сказать мне нечего

  52. Rodef:

    : Почему? Что у тебя за баттхёрт-то такой?

  53. Rodef:

    : Кроме поливания помоями можешь что-то сказать?

  54. NziSwet:

    : пхп 5.2, зенд оптимайзер, постгрескуль — это всё придётся держать на сервере, чтобы этот «продукт» работал. сообщения об ошибках невнятные, код закрыт зендом, так что сам не поймёшь, почему что-то не работает, один путь в техподдержку, которые (во всяком случае раньше) отвечали мне на запрос в течение пары недель.
    и это я только начал.

  55. Rodef:

    : А ты хочешь пистон, опенсорс и sqlite, что ли?

  56. Xxxhlam:

    : ну LAMP набором никого не удивишь, а вот с саппортом там и правда жопа

  57. Rodef:

    : А вот про техподдержку современную ничего не могу сказать, я с ними не контактирую :

  58. GVrin:

    : давай попроще, для начала: винда или линух/фря?

  59. GVrin:

    : мне абсолютно пофигу что нужно держать на сервере — я поставлю коробочный продукт на отдельную виртуалку.
    Мне нужно чтобы оно работало. Не падало. И пользователям нравилось.
    короче, я понял, это не сюда. у одминов свои критерии оценки софта.

  60. Rodef:

    : Лучше линуксы.

  61. Rodef:

    : Желательно, не vz, а нормальную виртуализацию тогда.

  62. GVrin:

    : hyper-v а под ним что угодно.

  63. Rodef:

    : Омг, его что, реально кто-то использует? Хотя работать должно без проблем.

  64. Xxxhlam:

    : используют, просто странно о нем читать на никс блоге

  65. R0bPhone:

    : vmware определенно, ну или на крайняк virtualbox

  66. NziSwet:

    : lamp это mysql, а не постгре

  67. NziSwet:

    : ага… попробуй собери 5.2.6 с openssl, раз тебе пофигу

  68. Xxxhlam:

    : да мне уже давно один хуй

  69. Xxxhlam:

    : я вообще лохе — у меня kvm в продакшене

  70. NziSwet:

    : моё мнение — хочешь мегаплан, покупай SaaS. коробка на самом деле это набор перемешанных деталей с невнятной инструкцией как это всё собирать и где брать недостающие детальки.

  71. Rodef:

    : Как раз наоборот.

  72. Rodef:

    : Чувак, вообще-то оно работает и на 5.3. Но совместимость со старыми версиями никто не ломает.

  73. NziSwet:

    : то есть когда эти чудилы в инструкции пишут «вам нужен пхп строго 5.2.6», это такой смешной прикол?
    Ну и да, не обманываешь ли ты? Zend Optimizer’а под 5.3 уже нет, например.

  74. Xxxhlam:

    : это красненьким же.

  75. GVrin:

    : Не очень большой проблемой будет купить коробку с установкой и саппортом. SaaS мы сейчас на тестовой площадке гоняем. Хочется коробку.

  76. GVrin:

    : а зачем мне что-то другое для винды? Чтобы бубен не пылился?

  77. NziSwet:

    : а чем SaaS не устраивает? за данные боитесь или чо?

  78. GVrin:

    : ну это вообще первоочередной вопрос, провайдеры любят утрачивать клиентские данные, им потом стыдно, а клиенту…

Добавить комментарий